CVE-2013-6638

NameCVE-2013-6638
DescriptionMultiple buffer overflows in runtime.cc in Google V8 before 3.22.24.7, as used in Google Chrome before 31.0.1650.63, allow remote attackers to cause a denial of service or possibly have unspecified other impact via vectors that trigger a large typed array, related to the (1) Runtime_TypedArrayInitialize and (2) Runtime_TypedArrayInitializeFromArrayLike functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2811-1
NVD severityhigh (attack range: remote)
Debian Bugs773671
Debian/oldoldstablepackages chromium-browser, libv8 are vulnerable.
Debian/oldstablepackage libv8 is vulnerable.
Debian/stablepackage libv8-3.14 is vulnerable; however, the security impact is unimportant.
Debian/testingpackage libv8-3.14 is vulnerable; however, the security impact is unimportant.
Debian/unstablepackage libv8-3.14 is vulnerable; however, the security impact is unimportant.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze, squeeze (security)6.0.472.63~r59945-5+squeeze6vulnerable
wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie43.0.2357.65-1~deb8u1fixed
jessie (security)44.0.2403.89-1~deb8u1fixed
stretch, sid44.0.2403.107-1fixed
libv8 (PTS)squeeze2.2.24-6vulnerable
wheezy3.8.9.20-2vulnerable
libv8-3.14 (PTS)stretch, sid, jessie3.14.5.8-8.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)31.0.1650.63-1high
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy31.0.1650.63-1~deb7u1highDSA-2811-1
libv8source(unstable)(unfixed)high
libv8sourcesqueeze(unfixed)end-of-life
libv8-3.14source(unstable)(unfixed)unimportant773671

Notes

[wheezy] - libv8 <no-dsa> (Minor issue, Chromium in Wheezy uses its own fixed copy)
[squeeze] - libv8 <end-of-life> (Unsupported in squeeze-lts)
libv8 not covered by security support

Search for package or bug name: Reporting problems