DescriptionMultiple off-by-one errors in Nagios Core 3.5.1, 4.0.2, and earlier, and Icinga before 1.8.5, 1.9 before 1.9.4, and 1.10 before 1.10.2 allow remote authenticated users to obtain sensitive information from process memory or cause a denial of service (crash) via a long string in the last key value in the variable list to the process_cgivars function in (1) avail.c, (2) cmd.c, (3) config.c, (4) extinfo.c, (5) histogram.c, (6) notifications.c, (7) outages.c, (8) status.c, (9) statusmap.c, (10) summary.c, and (11) trends.c in cgi/, which triggers a heap-based buffer over-read.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-60-1, DSA-2956-1
NVD severitymedium (attack range: remote)
Debian Bugs771466
Debian/oldoldstablepackages icinga, nagios3 are vulnerable.
Debian/oldstablepackage nagios3 is vulnerable.
Debian/stablepackage nagios3 is vulnerable.
Debian/testingnot vulnerable.
Debian/unstablepackage nagios3 is vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icinga (PTS)squeeze, squeeze (security)1.0.2-2+squeeze1vulnerable
squeeze (lts)1.0.2-2+squeeze2fixed
wheezy (security), wheezy1.7.1-7fixed
stretch, jessie1.11.6-1fixed
nagios3 (PTS)squeeze, squeeze (security)3.2.1-2+squeeze1vulnerable
sid, jessie3.5.1.dfsg-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[jessie] - nagios3 <no-dsa> (Minor issue)
[squeeze] - nagios3 <no-dsa> (Minor issue)
[wheezy] - nagios3 <no-dsa> (Minor issue)
separate CVE requested for nagios,

Search for package or bug name: Reporting problems