CVE-2013-7110

NameCVE-2013-7110
DescriptionTransifex command-line client before 0.10 does not validate X.509 certificates for data transfer connections, which allows man-in-the-middle attackers to spoof a Transifex server via an arbitrary certificate. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-2073.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
transifex-client (PTS)jessie0.11.1-1fixed
stretch0.12.2-1fixed
buster, sid0.13.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
transifex-clientsource(unstable)0.10-1medium
transifex-clientsourcewheezy(not affected)

Notes

[wheezy] - transifex-client <not-affected> (Incomplete patch was never released)
fix for CVE-2013-2073 was incorrect/incomplete
https://github.com/transifex/transifex-client/issues/42
https://github.com/transifex/transifex-client/commit/6d69d61

Search for package or bug name: Reporting problems