CVE-2014-0045

NameCVE-2014-0045
DescriptionThe needSamples method in AudioOutputSpeech.cpp in the client in Mumble 1.2.4 and the 1.2.3 pre-release snapshots, Mumble for iOS 1.1 through 1.2.2, and MumbleKit before commit fd190328a9b24d37382b269a5674b0c0c7a7e36d does not check the return value of the opus_decode_float function, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted Opus voice packet, which triggers an error in opus_decode_float, a conversion of a negative integer to an unsigned integer, and a heap-based buffer over-read and over-write.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2854-1
NVD severityhigh (attack range: remote)
Debian Bugs737739
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mumble (PTS)squeeze (security), squeeze1.2.2-6+squeeze1fixed
wheezy1.2.3-349-g315b5f5-2.2+deb7u2fixed
wheezy (security)1.2.3-349-g315b5f5-2.2+deb7u1fixed
jessie, sid1.2.8-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mumblesource(unstable)1.2.4-0.2high737739
mumblesourcesqueeze(not affected)
mumblesourcewheezy1.2.3-349-g315b5f5-2.2+deb7u1highDSA-2854-1

Notes

[squeeze] - mumble <not-affected> (Opus support not present)

Search for package or bug name: Reporting problems