CVE-2014-0060

NameCVE-2014-0060
DescriptionPostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 does not properly enforce the ADMIN OPTION restriction, which allows remote authenticated members of a role to add or remove arbitrary users to that role by calling the SET ROLE command before the associated GRANT command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2864-1, DSA-2865-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.21-0+deb7u1fixed
wheezy (security)9.1.23-0+deb7u1fixed
jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(unfixed)medium
postgresql-8.4sourcesqueeze8.4.20-0squeeze1mediumDSA-2864-1
postgresql-8.4sourcewheezy(not affected)
postgresql-9.1source(unstable)9.1.11-2medium
postgresql-9.1sourcewheezy9.1.12-0wheezy1mediumDSA-2865-1
postgresql-9.3source(unstable)9.3.3-1medium

Notes

[wheezy] - postgresql-8.4 <not-affected> (postgresql-8.4 in wheezy only provides PL/Perl)

Search for package or bug name: Reporting problems