CVE-2014-0061

NameCVE-2014-0061
DescriptionThe validator functions for the procedural languages (PLs) in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to gain privileges via a function that is (1) defined in another language or (2) not allowed to be directly called by the user due to permissions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2864-1, DSA-2865-1
NVD severitymedium (attack range: remote)
Debian/oldstablepackage postgresql-plsh is vulnerable.
Debian/stablepackage postgresql-plsh is vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)squeeze8.4.21-0squeeze1fixed
squeeze (security)8.4.20-0squeeze1fixed
squeeze (lts)8.4.22lts1-0+deb6u1fixed
wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.14-0+deb7u1fixed
wheezy (security)9.1.15-0+deb7u1fixed
jessie, sid9.1.15-0+deb8u1fixed
postgresql-plsh (PTS)squeeze1.3-3.1vulnerable
wheezy1.3-5vulnerable
jessie, sid1.20140221-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(unfixed)medium
postgresql-8.4sourcesqueeze8.4.20-0squeeze1mediumDSA-2864-1
postgresql-8.4sourcewheezy8.4.20-0wheezy1medium
postgresql-9.1source(unstable)9.1.12-1low
postgresql-9.1sourcewheezy9.1.12-0wheezy1mediumDSA-2865-1
postgresql-9.3source(unstable)9.3.3-1medium
postgresql-plshsource(unstable)1.20140221-1medium

Notes

[wheezy] - postgresql-plsh <no-dsa> (Minor issue)
[squeeze] - postgresql-plsh <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems