CVE-2014-0065

NameCVE-2014-0065
DescriptionMultiple buffer overflows in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to have unspecified impact and attack vectors, a different vulnerability than CVE-2014-0063.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2864-1, DSA-2865-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)squeeze8.4.21-0squeeze1fixed
squeeze (security)8.4.20-0squeeze1fixed
squeeze (lts)8.4.22lts4-0+deb6u1fixed
wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.14-0+deb7u1fixed
wheezy (security)9.1.16-0+deb7u2fixed
jessie (security), jessie9.1.16-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(unfixed)medium
postgresql-8.4sourcesqueeze8.4.20-0squeeze1mediumDSA-2864-1
postgresql-8.4sourcewheezy(not affected)
postgresql-9.1source(unstable)9.1.11-2medium
postgresql-9.1sourcewheezy9.1.12-0wheezy1mediumDSA-2865-1
postgresql-9.3source(unstable)9.3.3-1medium

Notes

[wheezy] - postgresql-8.4 <not-affected> (postgresql-8.4 in wheezy only provides PL/Perl)

Search for package or bug name: Reporting problems