CVE-2014-0083

NameCVE-2014-0083
DescriptionThe Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-net-ldap (PTS)stretch0.12.1-2fixed
bullseye, sid, buster0.16.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-net-ldapsource(unstable)(not affected)

Notes

- ruby-net-ldap <not-affected> (SSHA support not present)
SSHA support only from version v0.5.0, see #742706

Search for package or bug name: Reporting problems