CVE-2014-0150

NameCVE-2014-0150
DescriptionInteger overflow in the virtio_net_handle_mac function in hw/net/virtio-net.c in QEMU 2.0 and earlier allows local guest users to execute arbitrary code via a MAC addresses table update request, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2909-1, DSA-2910-1
NVD severitymedium (attack range: remote)
Debian Bugs744221
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)squeeze (security), squeeze0.12.5+dfsg-3squeeze4fixed
wheezy, wheezy (security)1.1.2+dfsg-6a+deb7u6fixed
jessie, sid1:2.1+dfsg-11fixed
qemu-kvm (PTS)squeeze (security), squeeze0.12.5+dfsg-5+squeeze11fixed
wheezy, wheezy (security)1.1.2+dfsg-6+deb7u6fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1.7.0+dfsg-8medium744221
qemusourcesqueeze0.12.5+dfsg-3squeeze4mediumDSA-2909-1
qemusourcewheezy1.1.2+dfsg-6a+deb7u1mediumDSA-2909-1
qemu-kvmsource(unstable)(unfixed)medium
qemu-kvmsourcesqueeze0.12.5+dfsg-5+squeeze11mediumDSA-2910-1
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u1mediumDSA-2910-1

Search for package or bug name: Reporting problems