CVE-2014-0240

NameCVE-2014-0240
DescriptionThe mod_wsgi module before 3.5 for Apache, when daemon mode is enabled, does not properly handle error codes returned by setuid when run on certain Linux kernels, which allows local users to gain privileges via vectors related to the number of running processes.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2937-1
NVD severitymedium (attack range: local)
Debian Bugs748910
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mod-wsgi (PTS)squeeze (security), squeeze3.3-2+deb6u1fixed
wheezy, wheezy (security)3.3-4+deb7u1fixed
jessie, sid4.3.0-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mod-wsgisource(unstable)3.5-1medium748910
mod-wsgisourcesqueeze3.3-2+deb6u1mediumDSA-2937-1
mod-wsgisourcewheezy3.3-4+deb7u1mediumDSA-2937-1

Notes

https://github.com/GrahamDumpleton/mod_wsgi/commit/d9d5fea585b23991f76532a9b07de7fcd3b649f4
only when running with linux >= 2.6.0 and < 3.1.0

Search for package or bug name: Reporting problems