CVE-2014-0471

NameCVE-2014-0471
DescriptionDirectory traversal vulnerability in the unpacking functionality in dpkg before 1.15.9, 1.16.x before 1.16.13, and 1.17.x before 1.17.8 allows remote attackers to write arbitrary files via a crafted source package, related to "C-style filename quoting."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2915-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpkg (PTS)squeeze, squeeze (security)1.15.11fixed
squeeze (lts)1.15.12fixed
wheezy1.16.15fixed
wheezy (security)1.16.16fixed
stretch, jessie1.17.25fixed
sid1.18.0fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpkgsource(unstable)1.17.8medium
dpkgsourcesqueeze1.15.9mediumDSA-2915-1
dpkgsourcewheezy1.16.13mediumDSA-2915-1

Search for package or bug name: Reporting problems