CVE-2014-1545

NameCVE-2014-1545
DescriptionMozilla Netscape Portable Runtime (NSPR) before 4.10.6 allows remote attackers to execute arbitrary code or cause a denial of service (out-of-bounds write) via vectors involving the sprintf and console functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-32-1, DSA-2955-1, DSA-2960-1, DSA-2962-1
NVD severityhigh (attack range: remote)
Debian/oldstablepackages icedove, iceweasel, nspr are vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15vulnerable
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.5.0-1~deb7u1fixed
jessie, sid31.5.0-1fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20vulnerable
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
jessie31.5.3esr-1fixed
sid31.6.0esr-1fixed
nspr (PTS)squeeze (security), squeeze4.8.6-1+squeeze1vulnerable
squeeze (lts)4.8.6-1+squeeze2fixed
wheezy, wheezy (security)2:4.9.2-1+deb7u2fixed
jessie2:4.10.7-1fixed
sid2:4.10.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)31.0~b1-1high
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy24.6.0-1~deb7u1highDSA-2960-1
iceweaselsource(unstable)30.0-1high
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy24.6.0esr-1~deb7u1highDSA-2955-1
nsprsource(unstable)2:4.10.6-1high
nsprsourcesqueeze4.8.6-1+squeeze2high
nsprsourcewheezy2:4.9.2-1+deb7u2highDSA-2962-1

Notes

Only the Wheezy builds use the bundled nspr

Search for package or bug name: Reporting problems