CVE-2014-1691

NameCVE-2014-1691
DescriptionThe framework/Util/lib/Horde/Variables.php script in the Util library in Horde before 5.1.1 allows remote attackers to conduct object injection attacks and execute arbitrary PHP code via a crafted serialized object in the _formvars form.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2853-1
NVD severityhigh (attack range: remote)
Debian Bugs737149
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
horde3 (PTS)squeeze (security), squeeze3.3.8+debian0-3fixed
php-horde-util (PTS)jessie, sid2.5.1-5fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
horde3source(unstable)(unfixed)medium737149
horde3sourcesqueeze3.3.8+debian0-3highDSA-2853-1
php-horde-utilsource(unstable)2.3.0-1high

Notes

https://github.com/horde/horde/commit/da6afc7e9f4e290f782eca9dbca794f772caccb3
https://github.com/horde/horde/commit/acf67ab4a633037849aca9e4a7592465b999ad93 is also required

Search for package or bug name: Reporting problems