CVE-2014-1730

NameCVE-2014-1730
DescriptionGoogle V8, as used in Google Chrome before 34.0.1847.131 on Windows and OS X and before 34.0.1847.132 on Linux, does not properly store internationalization metadata, which allows remote attackers to bypass intended access restrictions by leveraging "type confusion" and reading property values, related to i18n.js and runtime.cc.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2920-1
NVD severityhigh (attack range: remote)
Debian Bugs773671
Debian/oldstablepackages chromium-browser, libv8 are vulnerable.
Debian/stablepackage libv8 is vulnerable.
Debian/testingpackage libv8-3.14 is vulnerable; however, the security impact is unimportant.
Debian/unstablepackage libv8-3.14 is vulnerable; however, the security impact is unimportant.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze (security), squeeze6.0.472.63~r59945-5+squeeze6vulnerable
wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie41.0.2272.118-1fixed
sid42.0.2311.90-1fixed
libv8 (PTS)squeeze2.2.24-6vulnerable
wheezy3.8.9.20-2vulnerable
libv8-3.14 (PTS)jessie, sid3.14.5.8-8.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)34.0.1847.132-1high
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy34.0.1847.132-1~deb7u1highDSA-2920-1
libv8source(unstable)(unfixed)high
libv8sourcesqueeze(unfixed)end-of-life
libv8-3.14source(unstable)(unfixed)unimportant773671

Notes

[wheezy] - libv8 <no-dsa> (Minor issue, Chromium in Wheezy uses its own fixed copy)
[squeeze] - libv8 <end-of-life> (Unsupported in squeeze-lts)
libv8 not covered by security support

Search for package or bug name: Reporting problems