CVE-2014-1745

NameCVE-2014-1745
DescriptionUse-after-free vulnerability in the SVG implementation in Blink, as used in Google Chrome before 35.0.1916.114, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors that trigger removal of an SVGFontFaceElement object, related to core/svg/SVGFontFaceElement.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2939-1, DSA-5527-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.6-0+deb10u1vulnerable
bullseye2.42.2-1~deb11u1fixed
bullseye (security)2.42.5-1~deb11u1fixed
bookworm2.42.2-1~deb12u1fixed
bookworm (security)2.42.5-1~deb12u1fixed
sid, trixie2.42.5-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.38.6-1~deb11u1vulnerable
bookworm2.38.6-1vulnerable
trixie2.42.5-1fixed
sid2.42.5-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy35.0.1916.114-1~deb7u2DSA-2939-1
chromium-browsersource(unstable)35.0.1916.114-1
webkit2gtksourcebuster(unfixed)end-of-life
webkit2gtksourcebullseye2.42.1-1~deb11u1DSA-5527-1
webkit2gtksourcebookworm2.42.1-1~deb12u1DSA-5527-1
webkit2gtksource(unstable)2.42.0-1
wpewebkitsource(unstable)2.42.0-1

Notes

[buster] - webkit2gtk <end-of-life> (EOL in buster LTS)
[bookworm] - wpewebkit <ignored> (wpewebkit not covered by security support in Bookworm)
[bullseye] - wpewebkit <ignored> (wpewebkit >= 2.40 can no longer be sensibly backported)
https://webkitgtk.org/security/WSA-2024-0001.html

Search for package or bug name: Reporting problems