CVE-2014-1830

NameCVE-2014-1830
DescriptionRequests (aka python-requests) before 2.3.0 allows remote servers to obtain sensitive information by reading the Proxy-Authorization header in a redirected request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3146-1
NVD severitymedium
Debian Bugs733108

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
requests (PTS)stretch2.12.4-1fixed
buster2.21.0-1fixed
bookworm, sid, bullseye2.25.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
requestssourcewheezy0.12.1-1+deb7u1DSA-3146-1
requestssource(unstable)2.3.0-1733108

Notes

https://github.com/kennethreitz/requests/issues/1885

Search for package or bug name: Reporting problems