Information on source package requests

Available versions

ReleaseVersion
jessie2.4.3-6
stretch2.12.4-1
buster2.21.0-1
bullseye2.21.0-1
sid2.21.0-1

Open issues

BugjessiestretchbusterbullseyesidDescription
CVE-2018-18074vulnerable (no DSA, postponed)vulnerable (no DSA)fixedfixedfixedThe Requests package before 2.20.0 for Python sends an HTTP Authorizat ...

Resolved issues

BugDescription
CVE-2015-2296The resolve_redirects function in sessions.py in requests 2.1.0 throug ...
CVE-2014-1830Requests (aka python-requests) before 2.3.0 allows remote servers to o ...
CVE-2014-1829Requests (aka python-requests) before 2.3.0 allows remote servers to o ...

Security announcements

DSA / DLADescription
DSA-3146-1requests - security update

Search for package or bug name: Reporting problems