CVE-2014-1859

NameCVE-2014-1859
Descriptioninsecure temporary file use
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
Debian Bugs737778

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-numpy (PTS)wheezy1:1.6.2-1.2vulnerable
jessie1:1.8.2-2fixed
stretch1:1.12.1-3fixed
buster, sid1:1.13.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-numpysource(unstable)1:1.8.1~rc1-1low737778

Notes

[squeeze] - python-numpy <no-dsa> (Minor issue)
[wheezy] - python-numpy <no-dsa> (Minor issue)
issue fixed by https://github.com/numpy/numpy/commit/0bb46c1448b0d3f5453d5182a17ea7ac5854ee15

Search for package or bug name: Reporting problems