CVE-2014-2525

NameCVE-2014-2525
DescriptionHeap-based buffer overflow in the yaml_parser_scan_uri_escapes function in LibYAML before 0.1.6 allows context-dependent attackers to execute arbitrary code via a long sequence of percent-encoded characters in a URI in a YAML file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2884-1, DSA-2885-1
NVD severitymedium (attack range: remote)
Debian Bugs742732
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libyaml (PTS)squeeze, squeeze (security)0.1.3-1+deb6u4fixed
squeeze (lts)0.1.3-1+deb6u5fixed
wheezy (security), wheezy0.1.4-2+deb7u5fixed
stretch, sid, jessie0.1.6-3fixed
libyaml-libyaml-perl (PTS)squeeze, squeeze (security)0.33-1+squeeze3fixed
squeeze (lts)0.33-1+squeeze4fixed
wheezy (security), wheezy0.38-3+deb7u3fixed
stretch, sid, jessie0.41-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libyamlsource(unstable)0.1.4-3.2medium742732
libyamlsourcesqueeze0.1.3-1+deb6u4mediumDSA-2884-1
libyamlsourcewheezy0.1.4-2+deb7u4mediumDSA-2884-1
libyaml-libyaml-perlsource(unstable)0.41-5medium
libyaml-libyaml-perlsourcesqueeze0.33-1+squeeze3mediumDSA-2885-1
libyaml-libyaml-perlsourcewheezy0.38-3+deb7u2mediumDSA-2885-1

Notes

http://www.ocert.org/advisories/ocert-2014-003.html

Search for package or bug name: Reporting problems