CVE-2014-2707

NameCVE-2014-2707
Descriptioncups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs743470

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups-filters (PTS)stretch (security), stretch1.11.6-3+deb9u1fixed
buster1.21.6-5fixed
bullseye1.28.7-1fixed
bookworm, sid1.28.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cups-filterssourcewheezy(not affected)
cups-filterssource(unstable)1.0.51-1743470

Notes

[wheezy] - cups-filters <not-affected> (vulnerable code not present)
Introduced in at least 1.0.41

Search for package or bug name: Reporting problems