CVE-2014-2744

NameCVE-2014-2744
Descriptionplugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2895-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lua-expat (PTS)jessie1.3.0-2fixed
buster, sid, stretch1.3.0-4fixed
prosody (PTS)jessie (security), jessie0.9.7-2+deb8u4fixed
stretch (security), stretch0.9.12-2+deb9u2fixed
buster, sid0.11.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lua-expatsource(unstable)1.3.0-1high
lua-expatsourcewheezy1.2.0-5+deb7u1high
prosodysource(unstable)0.9.4-1high
prosodysourcewheezy0.8.2-4+deb7u1highDSA-2895-1

Notes

[squeeze] - lua-expat <no-dsa> (Minor issue)
[squeeze] - prosody <no-dsa> (Minor issue)
http://hg.prosody.im/0.9/rev/b3b1c9da38fb

Search for package or bug name: Reporting problems