CVE-2014-2892

NameCVE-2014-2892
DescriptionHeap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2916-1
NVD severityhigh (attack range: remote)
Debian Bugs745301
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmms (PTS)squeeze, squeeze (security)0.6-1+squeeze2fixed
wheezy, wheezy (security)0.6.2-3+deb7u1fixed
stretch, jessie, sid0.6.2-4fixed
xine-lib (PTS)squeeze1.1.19-2fixed
wheezy1.1.21-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmmssource(unstable)0.6.2-4high745301
libmmssourcesqueeze0.6-1+squeeze2highDSA-2916-1
libmmssourcewheezy0.6.2-3+deb7u1highDSA-2916-1
xine-libsource(unstable)(not affected)

Notes

- xine-lib <not-affected> (mmsh is libmms-specific)
http://sourceforge.net/p/libmms/code/ci/03bcfccc22919c72742b7338d02859962861e0e8

Search for package or bug name: Reporting problems