CVE-2014-3121

NameCVE-2014-3121
Descriptionrxvt-unicode before 9.20 does not properly handle OSC escape sequences, which allows user-assisted remote attackers to manipulate arbitrary X window properties and execute arbitrary commands.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2925-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs746593
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rxvt-unicode (PTS)squeeze (security), squeeze9.07-2+deb6u1fixed
wheezy, wheezy (security)9.15-2+deb7u1fixed
jessie9.20-1fixed
sid9.21-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rxvt-unicodesource(unstable)9.20-1high746593
rxvt-unicodesourcesqueeze9.07-2+deb6u1highDSA-2925-1
rxvt-unicodesourcewheezy9.15-2+deb7u1highDSA-2925-1

Search for package or bug name: Reporting problems