CVE-2014-3158

NameCVE-2014-3158
DescriptionInteger overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-74-1, DSA-3079-1
NVD severityhigh (attack range: remote)
Debian Bugs762789

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ppp (PTS)wheezy, wheezy (security)2.4.5-5.1+deb7u2fixed
jessie2.4.6-3.1fixed
buster, stretch, sid2.4.7-1+4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pppsource(unstable)2.4.6-3medium762789
pppsourcesqueeze2.4.5-4+deb6u1highDLA-74-1
pppsourcewheezy2.4.5-5.1+deb7u1highDSA-3079-1

Notes

https://github.com/paulusmack/ppp/commit/7658e8257183f062dc01f87969c140707c7e52cb
http://marc.info/?l=linux-ppp&m=140764978420764
No known exploit yet but potential local privilege escalation to root for users in "dip" group

Search for package or bug name: Reporting problems