CVE-2014-3243

NameCVE-2014-3243
DescriptionSOAPpy 0.12.5 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted SOAP request containing a large number of nested entity references.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs747280

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-soappy (PTS)wheezy0.12.0-4vulnerable
buster, sid, jessie, stretch0.12.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-soappysource(unstable)0.12.22-1low747280

Notes

[squeeze] - python-soappy <no-dsa> (Minor issue)
[wheezy] - python-soappy <no-dsa> (Minor issue)
http://www.pnigos.com/?p=260

Search for package or bug name: Reporting problems