CVE-2014-3251

NameCVE-2014-3251
DescriptionThe MCollective aes_security plugin, as used in Puppet Enterprise before 3.3.0 and Mcollective before 2.5.3, does not properly validate new server certificates based on the CA certificate, which allows local users to establish unauthorized Mcollective connections via unspecified vectors related to a race condition.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs758701

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mcollective (PTS)jessie2.6.0+dfsg-2.1fixed
bullseye, sid, buster2.12.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mcollectivesource(unstable)2.6.0+dfsg-1low758701

Notes

[wheezy] - mcollective <no-dsa> (Minor issue)
Mcollective are not configured to use the plugin and are not vulnerable by default.
http://puppetlabs.com/security/cve/cve-2014-3251

Search for package or bug name: Reporting problems