CVE-2014-3693

NameCVE-2014-3693
DescriptionUse-after-free vulnerability in the socket manager of Impress Remote in LibreOffice 4.x before 4.2.7 and 4.3.x before 4.3.3 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted request to TCP port 1599.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)stretch (security), stretch1:5.2.7-1+deb9u11fixed
buster1:6.1.5-3+deb10u7fixed
buster (security)1:6.1.5-3+deb10u4fixed
bullseye1:7.0.4-4fixed
bullseye (security)1:7.0.4-4+deb11u1fixed
bookworm, sid1:7.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesourcewheezy(not affected)
libreofficesource(unstable)1:4.3.3~rc2~git20141011-1

Notes

[wheezy] - libreoffice <not-affected> (Introduced in 4.0.0)
https://www.libreoffice.org/about-us/security/advisories/CVE-2014-3693/

Search for package or bug name: Reporting problems