CVE-2014-4338

NameCVE-2014-4338
Descriptioncups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups-filters (PTS)stretch, stretch (security)1.11.6-3+deb9u1fixed
buster1.21.6-5fixed
bullseye1.28.7-1fixed
bookworm, sid1.28.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cups-filterssourcewheezy(not affected)
cups-filterssource(unstable)1.0.53-1

Notes

[wheezy] - cups-filters <not-affected> (vulnerable code not present)
http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7195

Search for package or bug name: Reporting problems