CVE-2014-4946

NameCVE-2014-4946
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in Horde Internet Mail Program (IMP) before 6.1.8, as used in Horde Groupware Webmail Edition before 5.1.5, allow remote attackers to inject arbitrary web script or HTML via (1) unspecified flags or (2) a mailbox name in the dynamic mailbox view.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-horde-imp (PTS)jessie6.2.2-3fixed
stretch6.2.17-2fixed
buster, sid6.2.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
horde3source(unstable)(unfixed)medium
horde3sourcesqueeze(not affected)
php-horde-impsource(unstable)6.2.0-1medium

Notes

Upstream patches:
https://github.com/horde/horde/commit/578ff073724d9c179663098d8ff0076e8b361cfb
https://github.com/horde/horde/commit/2f1f4b10dec90fb67797ea80be0e029ead90f168
The bugs are in javascript files that do not exist in the version in Squeeze.

Search for package or bug name: Reporting problems