CVE-2014-5008

NameCVE-2014-5008
DescriptionSnoopy allows remote attackers to execute arbitrary commands.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-357-1, DSA-3248-1
NVD severityhigh (attack range: remote)
Debian Bugs778634

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libphp-snoopy (PTS)wheezy, wheezy (security)2.0.0-1~deb7u1fixed
jessie2.0.0-1fixed
buster, sid, stretch2.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libphp-snoopysource(unstable)2.0.0-1high778634
libphp-snoopysourcesqueeze2.0.0-1~deb6u1highDLA-357-1
libphp-snoopysourcewheezy2.0.0-1~deb7u1highDSA-3248-1

Notes

http://mstrokin.com/sec/feed2js-magpierss-0day-vulnerability-not-really-it-is-actually-cve-2005-3330-cve-2008-4796/
This issue exists because of an incorrect fix for CVE-2008-4796 (i.e., use of escapeshellcmd where escapeshellarg was required).

Search for package or bug name: Reporting problems