CVE-2014-6040

NameCVE-2014-6040
DescriptionGNU C Library (aka glibc) before 2.20 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via a multibyte character value of "0xffff" to the iconv function when converting (1) IBM933, (2) IBM935, (3) IBM937, (4) IBM939, or (5) IBM1364 encoded data to UTF-8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-97-1, DSA-3142-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie (security), jessie2.19-18+deb8u10fixed
stretch (security), stretch2.24-11+deb9u1fixed
buster, sid2.24-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcesqueeze2.11.3-4+deb6u2mediumDLA-97-1
eglibcsourcewheezy2.13-38+deb7u7mediumDSA-3142-1
glibcsource(unstable)2.19-12medium

Notes

[wheezy] - eglibc <no-dsa> (Will be fixed in a point update)
https://sourceware.org/bugzilla/show_bug.cgi?id=17325
https://sourceware.org/ml/libc-alpha/2014-08/msg00473.html

Search for package or bug name: Reporting problems