CVE-2014-6051

NameCVE-2014-6051
DescriptionInteger overflow in the MallocFrameBuffer function in vncviewer.c in LibVNCServer 0.9.9 and earlier allows remote VNC servers to cause a denial of service (crash) and possibly execute arbitrary code via an advertisement for a large screen size, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-197-1, DSA-3081-1
NVD severityhigh (attack range: remote)
Debian Bugs762745

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)wheezy0.9.9+dfsg-1+deb7u1fixed
wheezy (security)0.9.9+dfsg-1+deb7u2fixed
jessie (security), jessie0.9.9+dfsg2-6.1+deb8u2fixed
buster, stretch, sid0.9.11+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversource(unstable)0.9.9+dfsg-6.1high762745
libvncserversourcesqueeze0.9.7-2+deb6u1highDLA-197-1
libvncserversourcewheezy0.9.9+dfsg-1+deb7u1highDSA-3081-1

Notes

https://github.com/newsoft/libvncserver/commit/045a044e8ae79db9244593fbce154cdf6e843273

Search for package or bug name: Reporting problems