CVE-2014-6495

NameCVE-2014-6495
DescriptionUnspecified vulnerability in Oracle MySQL Server 5.5.38 and earlier, and 5.6.19 and earlier, allows remote attackers to affect availability via vectors related to SERVER:SSL:yaSSL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3054-1
NVD severitymedium (attack range: remote)
Debian Bugs770229

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.30-0+deb8u2fixed
jessie (security)10.0.32-0+deb8u1fixed
mysql-5.5 (PTS)wheezy5.5.47-0+deb7u1fixed
wheezy (security)5.5.58-0+deb7u1fixed
jessie (security), jessie5.5.58-0+deb8u1fixed
wolfssl (PTS)buster, sid3.12.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cyasslsource(unstable)(unfixed)medium770229
mariadb-10.0source(unstable)(not affected)
mariadb-5.5source(unstable)5.5.39-1medium
mysql-5.5source(unstable)5.5.39-1medium
mysql-5.5sourcewheezy5.5.40-0+wheezy1mediumDSA-3054-1
percona-xtradb-cluster-5.5source(unstable)(unfixed)medium
wolfsslsource(unstable)(not affected)

Notes

- mariadb-10.0 <not-affected> (Fixed before initial upload)
- wolfssl <not-affected> (WolfSSL not affected)

Search for package or bug name: Reporting problems