CVE-2014-6585

NameCVE-2014-6585
DescriptionUnspecified vulnerability in Oracle Java SE 5.0u75, 6u85, 7u72, and 8u25 allows remote attackers to affect confidentiality via unknown vectors related to 2D, a different vulnerability than CVE-2014-6591.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-157-1, DLA-219-1, DSA-3144-1, DSA-3147-1, DSA-3187-1
NVD severitylow (attack range: remote)
Debian Bugs776264

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icu (PTS)wheezy4.8.1.1-12+deb7u3fixed
wheezy (security)4.8.1.1-12+deb7u7fixed
jessie52.1-8+deb8u6fixed
jessie (security)52.1-8+deb8u5fixed
stretch57.1-6+deb9u1fixed
buster, sid57.1-8fixed
openjdk-6 (PTS)wheezy, wheezy (security)6b38-1.13.10-1~deb7u1fixed
openjdk-7 (PTS)wheezy7u95-2.6.4-1~deb7u1fixed
wheezy (security)7u151-2.6.11-2~deb7u3fixed
jessie7u111-2.6.7-1~deb8u1fixed
jessie (security)7u151-2.6.11-2~deb8u1fixed
openjdk-8 (PTS)stretch, stretch (security)8u151-b12-1~deb9u1fixed
buster, sid8u151-b12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icusource(unstable)52.1-7.1low776264
icusourcesqueeze4.4.1-8+squeeze3lowDLA-219-1
icusourcewheezy4.8.1.1-12+deb7u2lowDSA-3187-1
openjdk-6source(unstable)6b34-1.13.6-1low
openjdk-6sourcesqueeze6b34-1.13.6-1~deb6u1lowDLA-157-1
openjdk-6sourcewheezy6b34-1.13.6-1~deb7u1lowDSA-3147-1
openjdk-7source(unstable)7u75-2.5.4-1low
openjdk-7sourcewheezy7u75-2.5.4-1~deb7u1lowDSA-3144-1
openjdk-8source(unstable)8u40~b22-1low

Search for package or bug name: Reporting problems