CVE-2014-7192

NameCVE-2014-7192
DescriptionEval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs773623

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libv8 (PTS)wheezy3.8.9.20-2vulnerable
libv8-3.14 (PTS)jessie3.14.5.8-8.1vulnerable
sid, stretch3.14.5.8-11vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libv8source(unstable)(unfixed)high
libv8sourcesqueeze(unfixed)end-of-life
libv8-3.14source(unstable)(unfixed)unimportant773623

Notes

[wheezy] - libv8 <no-dsa> (Minor issue, Chromium in Wheezy uses its own fixed copy)
[squeeze] - libv8 <end-of-life> (Unsupported in squeeze-lts)
libv8 not covered by security support

Search for package or bug name: Reporting problems