CVE-2014-7817

NameCVE-2014-7817
DescriptionThe wordexp function in GNU C Library (aka glibc) 2.21 does not enforce the WRDE_NOCMD flag, which allows context-dependent attackers to execute arbitrary commands, as demonstrated by input containing "$((`...`))".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-97-1, DSA-3142-1
NVD severitymedium (attack range: local)
Debian Bugs775572

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie2.19-18+deb8u9fixed
jessie (security)2.19-18+deb8u10fixed
stretch2.24-11fixed
stretch (security)2.24-11+deb9u1fixed
buster, sid2.24-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcesqueeze2.11.3-4+deb6u2mediumDLA-97-1
eglibcsourcewheezy2.13-38+deb7u7mediumDSA-3142-1
glibcsource(unstable)2.19-14medium775572

Notes

[wheezy] - eglibc <no-dsa> (Will be fixed through a point update)
https://sourceware.org/ml/libc-alpha/2014-11/msg00519.html
Git commit: https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=a39208bd7fb76c1b01c127b4c61f9bfd915bfe7c

Search for package or bug name: Reporting problems