CVE-2014-8147

NameCVE-2014-8147
DescriptionThe resolveImplicitLevels function in common/ubidi.c in the Unicode Bidirectional Algorithm implementation in ICU4C in International Components for Unicode (ICU) before 55.1 uses an integer data type that is inconsistent with a header file, which allows remote attackers to cause a denial of service (incorrect malloc followed by invalid free) or possibly execute arbitrary code via crafted text.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3323-1
NVD severityhigh
Debian Bugs784773

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)stretch70.0.3538.110-1~deb9u1fixed
stretch (security)71.0.3578.80-1~deb9u1fixed
icu (PTS)stretch (security), stretch57.1-6+deb9u4fixed
buster, buster (security)63.1-6+deb10u1fixed
bullseye, sid67.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy(not affected)
chromium-browsersourcejessie42.0.2311.135-1~deb8u1
chromium-browsersource(unstable)42.0.2311.135-1
icusourcesqueeze(not affected)
icusourcewheezy4.8.1.1-12+deb7u3DSA-3323-1
icusourcejessie52.1-8+deb8u2DSA-3323-1
icusource(unstable)52.1-9784773

Notes

[wheezy] - icu <not-affected> (Vulnerable code not present)
[squeeze] - icu <not-affected> (Vulnerable code not present)
[wheezy] - chromium-browser <not-affected> (Vulnerable code not present)
[squeeze] - chromium-browser <end-of-life> (Not supported in Squeeze LTS)
Patch: http://bugs.icu-project.org/trac/changeset/37080

Search for package or bug name: Reporting problems