CVE-2014-8240

NameCVE-2014-8240
DescriptionInteger overflow in TigerVNC allows remote VNC servers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to screen size handling, which triggers a heap-based buffer overflow, a similar issue to CVE-2014-6051.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs849479

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tigervnc (PTS)stretch1.7.0+dfsg-7+deb9u1fixed
buster1.9.0+dfsg-3+deb10u2fixed
bullseye, sid1.10.1+dfsg-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tigervncsource(unstable)1.7.0-1849479

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1151307
Patch https://bugzilla.redhat.com/attachment.cgi?id=947578 is not applied

Search for package or bug name: Reporting problems