Information on source package tigervnc

Available versions

ReleaseVersion
stretch1.7.0+dfsg-7
buster1.9.0+dfsg-3
bullseye1.10.1+dfsg-1
sid1.10.1+dfsg-1

Open issues

BugstretchbusterbullseyesidDescription
CVE-2019-15695vulnerable (no DSA)vulnerable (no DSA)fixedfixedTigerVNC version prior to 1.10.1 is vulnerable to stack buffer overflo ...
CVE-2019-15694vulnerable (no DSA)vulnerable (no DSA)fixedfixedTigerVNC version prior to 1.10.1 is vulnerable to heap buffer overflow ...
CVE-2019-15693vulnerable (no DSA)vulnerable (no DSA)fixedfixedTigerVNC version prior to 1.10.1 is vulnerable to heap buffer overflow ...
CVE-2019-15692vulnerable (no DSA)vulnerable (no DSA)fixedfixedTigerVNC version prior to 1.10.1 is vulnerable to heap buffer overflow ...
CVE-2019-15691vulnerable (no DSA)vulnerable (no DSA)fixedfixedTigerVNC version prior to 1.10.1 is vulnerable to stack use-after-retu ...

Resolved issues

BugDescription
CVE-2017-7396In TigerVNC 1.7.1 (CConnection.cxx CConnection::CConnection), an unaut ...
CVE-2017-7395In TigerVNC 1.7.1 (SMsgReader.cxx SMsgReader::readClientCutText), by c ...
CVE-2017-7394In TigerVNC 1.7.1 (SSecurityPlain.cxx SSecurityPlain::processMsg), una ...
CVE-2017-7393In TigerVNC 1.7.1 (VNCSConnectionST.cxx VNCSConnectionST::fence), an a ...
CVE-2017-7392In TigerVNC 1.7.1 (SSecurityVeNCrypt.cxx SSecurityVeNCrypt::SSecurityV ...
CVE-2017-5581Buffer overflow in the ModifiablePixelBuffer::fillRect function in Tig ...
CVE-2016-10207The Xvnc server in TigerVNC allows remote attackers to cause a denial ...
CVE-2014-8241XRegion in TigerVNC allows remote VNC servers to cause a denial of ser ...
CVE-2014-8240Integer overflow in TigerVNC allows remote VNC servers to cause a deni ...
CVE-2014-0011Multiple heap-based buffer overflows in the ZRLE_DECODE function in co ...
CVE-2011-1775The CSecurityTLS::processMsg function in common/rfb/CSecurityTLS.cxx i ...

Search for package or bug name: Reporting problems