CVE-2014-8583

NameCVE-2014-8583
Descriptionmod_wsgi before 4.2.4 for Apache, when creating a daemon process group, does not properly handle when group privileges cannot be dropped, which might allow attackers to gain privileges via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mod-wsgi (PTS)jessie4.3.0-1fixed
stretch4.5.11-1fixed
bullseye, sid, buster4.6.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mod-wsgisource(unstable)4.2.7-1medium

Notes

[wheezy] - mod-wsgi <no-dsa> (Minor issue)
[squeeze] - mod-wsgi <no-dsa> (Minor issue)
https://github.com/GrahamDumpleton/mod_wsgi/commit/545354a80b9cc20d8b6916ca30542eab36c3b8bd

Search for package or bug name: Reporting problems