Descriptionmod_wsgi before 4.2.4 for Apache, when creating a daemon process group, does not properly handle when group privileges cannot be dropped, which might allow attackers to gain privileges via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mod-wsgi (PTS)buster4.6.5-1fixed
buster (security)4.6.5-1+deb10u1fixed
bookworm, sid4.9.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[wheezy] - mod-wsgi <no-dsa> (Minor issue)
[squeeze] - mod-wsgi <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems