CVE-2014-8760

NameCVE-2014-8760
Descriptionejabberd before 2.1.13 does not enforce the starttls_required setting when compression is used, which causes clients to establish connections without encryption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-881-1
NVD severitymedium (attack range: remote)
Debian Bugs767535

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ejabberd (PTS)jessie14.07-4+deb8u3fixed
stretch16.09-4fixed
buster18.12.1-2fixed
bullseye19.05-2fixed
sid19.08-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ejabberdsource(unstable)14.07-3low767535
ejabberdsourcewheezy2.1.10-4+deb7u2mediumDLA-881-1

Notes

[squeeze] - ejabberd <no-dsa> (Minor issue)
http://mail.jabber.org/pipermail/operators/2014-October/002438.html
Patch https://github.com/processone/ejabberd/commit/7bdc1151b

Search for package or bug name: Reporting problems