CVE-2014-9018

NameCVE-2014-9018
DescriptionIcecast before 2.4.1 transmits the output of the on-connect script, which might allow remote attackers to obtain sensitive information, related to shared file descriptors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs770222

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icecast2 (PTS)stretch (security), stretch2.4.2-1+deb9u1fixed
buster2.4.4-1fixed
bookworm, bullseye, sid2.4.4-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icecast2source(unstable)2.4.0-1.1770222

Notes

[wheezy] - icecast2 <no-dsa> (Minor issue)
[squeeze] - icecast2 <no-dsa> (Minor issue)
https://trac.xiph.org/ticket/2089

Search for package or bug name: Reporting problems