CVE-2014-9494

NameCVE-2014-9494
DescriptionRabbitMQ before 3.4.0 allows remote attackers to bypass the loopback_users restriction via a crafted X-Forwareded-For header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs773134

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rabbitmq-server (PTS)jessie (security), jessie3.3.5-1.1+deb8u1fixed
stretch3.6.6-1fixed
buster3.7.8-4fixed
bullseye, sid3.7.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rabbitmq-serversource(unstable)3.4.1-1773134
rabbitmq-serversourcejessie3.3.5-1.1
rabbitmq-serversourcesqueeze(not affected)
rabbitmq-serversourcewheezy(not affected)

Notes

[wheezy] - rabbitmq-server <not-affected> (does not have this access control mechanism)
[squeeze] - rabbitmq-server <not-affected> (does not have this access control mechanism)
http://hg.rabbitmq.com/rabbitmq-management/rev/c3c41177a11a
http://hg.rabbitmq.com/rabbitmq-management/rev/35e916df027d
http://www.rabbitmq.com/release-notes/README-3.4.0.txt

Search for package or bug name: Reporting problems