CVE-2014-9862

NameCVE-2014-9862
DescriptionInteger signedness error in bspatch.c in bspatch in bsdiff, as used in Apple OS X before 10.11.6 and other products, allows remote attackers to execute arbitrary code or cause a denial of service (heap-based buffer overflow) via a crafted patch file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-697-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bsdiff (PTS)jessie4.3-15vulnerable
stretch4.3-19fixed
buster, sid4.3-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bsdiffsource(unstable)4.3-17high
bsdiffsourcewheezy4.3-14+deb7u1highDLA-697-1

Notes

[jessie] - bsdiff <no-dsa> (Minor issue; can be fixed via point release)
https://bugs.chromium.org/p/chromium/issues/detail?id=372525

Search for package or bug name: Reporting problems