CVE-2014-9938

NameCVE-2014-9938
Descriptioncontrib/completion/git-prompt.sh in Git before 1.9.3 does not sanitize branch names in the PS1 variable, allowing a malicious repository to cause code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)wheezy (security), wheezy1:1.7.10.4-1+wheezy3fixed
jessie (security), jessie1:2.1.4-2.1+deb8u2fixed
stretch, sid1:2.11.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)1:2.0.0~rc2-1medium
gitsourcewheezy(not affected)

Notes

[wheezy] - git <not-affected> (Vulnerable code introduced in 1.8.1-rc0)
https://github.com/git/git/commit/8976500cbbb13270398d3b3e07a17b8cc7bff43f
https://github.com/njhartwell/pw3nage
Vulnerability likely introduced by the "pc_mode" in https://github.com/git/git/commit/1bfc51ac814125de03ddf1900245e42d6ce0d250

Search for package or bug name: Reporting problems