CVE-2015-0797

NameCVE-2015-0797
DescriptionGStreamer before 1.4.5, as used in Mozilla Firefox before 38.0, Firefox ESR 31.x before 31.7, and Thunderbird before 31.7 on Linux, allows remote attackers to cause a denial of service (buffer over-read and application crash) or possibly execute arbitrary code via crafted H.264 video data in an m4v file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2164-1, DSA-3225-1, DSA-3260-1, DSA-3264-1
NVD severitymedium
Debian Bugs784220

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-bad0.10source(unstable)(unfixed)784220
gst-plugins-bad0.10sourcejessie0.10.23-7.4+deb8u3DLA-2164-1
gst-plugins-bad0.10sourcesqueeze(not affected)
gst-plugins-bad0.10sourcewheezy0.10.23-7.1+deb7u2DSA-3225-1
icedovesource(unstable)31.7.0-1
icedovesourcejessie31.7.0-1~deb8u1DSA-3264-1
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy31.7.0-1~deb7u1DSA-3264-1
iceweaselsource(unstable)38.0-1
iceweaselsourcejessie31.7.0esr-1~deb8u1DSA-3260-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy31.7.0esr-1~deb7u1DSA-3260-1

Notes

[squeeze] - gst-plugins-bad0.10 <not-affected> (vulnerable code (gst/videoparsers/*) introduced later)
https://www.mozilla.org/en-US/security/advisories/mfsa2015-47/

Search for package or bug name: Reporting problems