CVE-2015-0847

NameCVE-2015-0847
Descriptionnbd-server.c in Network Block Device (nbd-server) before 3.11 does not properly handle signals, which allows remote attackers to cause a denial of service (deadlock) via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-223-1, DSA-3271-1
NVD severityhigh (attack range: remote)
Debian Bugs784657

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nbd (PTS)wheezy, wheezy (security)1:3.2-4~deb7u5fixed
jessie1:3.8-4+deb8u3fixed
jessie (security)1:3.8-4+deb8u1fixed
stretch1:3.15.2-3fixed
buster, sid1:3.16.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nbdsource(unstable)1:3.10-1high784657
nbdsourcejessie1:3.8-4+deb8u1highDSA-3271-1
nbdsourcesqueeze1:2.9.16-8+squeeze2highDLA-223-1
nbdsourcewheezy1:3.2-4~deb7u5highDSA-3271-1

Notes

http://sourceforge.net/p/nbd/mailman/message/34091218/

Search for package or bug name: Reporting problems