CVE-2015-0852

NameCVE-2015-0852
DescriptionMultiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-327-1, DSA-3392-1
NVD severitymedium (attack range: remote)
Debian Bugs797165

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeimage (PTS)wheezy3.15.1-1.1fixed
wheezy (security)3.15.1-1.1+deb7u1fixed
jessie (security), jessie3.15.4-4.2+deb8u1fixed
buster, sid, stretch3.17.0+ds1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeimagesource(unstable)3.15.4-5medium797165
freeimagesourcejessie3.15.4-4.2mediumDSA-3392-1
freeimagesourcesqueeze3.10.0-4+deb6u1mediumDLA-327-1
freeimagesourcewheezy3.15.1-1.1mediumDSA-3392-1

Notes

http://freeimage.cvs.sourceforge.net/viewvc/freeimage/FreeImage/Source/FreeImage/PluginPCX.cpp?r1=1.17&r2=1.18&pathrev=MAIN
http://freeimage.cvs.sourceforge.net/viewvc/freeimage/FreeImage/Source/FreeImage/PluginPCX.cpp?r1=1.18&r2=1.19&pathrev=MAIN

Search for package or bug name: Reporting problems