CVE-2015-0859

NameCVE-2015-0859
DescriptionThe Debian build procedure for the smokeping package in wheezy before 2.6.8-2+deb7u1 and jessie before 2.6.9-1+deb8u1 does not properly configure the way Apache httpd passes arguments to smokeping_cgi, which allows remote attackers to execute arbitrary code via crafted CGI arguments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3405-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smokeping (PTS)wheezy, wheezy (security)2.6.8-2+deb7u1fixed
jessie (security), jessie2.6.9-1+deb8u1fixed
sid, stretch2.6.11-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smokepingsource(unstable)2.6.11-2high
smokepingsourcejessie2.6.9-1+deb8u1highDSA-3405-1
smokepingsourcesqueeze(not affected)
smokepingsourcewheezy2.6.8-2+deb7u1highDSA-3405-1

Notes

[squeeze] - smokeping <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems