CVE-2015-0860

NameCVE-2015-0860
DescriptionOff-by-one error in the extracthalf function in dpkg-deb/extract.c in the dpkg-deb component in Debian dpkg 1.16.x before 1.16.17 and 1.17.x before 1.17.26 allows remote attackers to execute arbitrary code via the archive magic version number in an "old-style" Debian binary package, which triggers a stack-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3407-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpkg (PTS)buster, buster (security)1.19.8fixed
bullseye1.20.12fixed
bullseye (security)1.20.10fixed
bookworm, sid1.21.9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpkgsourcesqueeze(not affected)
dpkgsourcewheezy1.16.17DSA-3407-1
dpkgsourcejessie1.17.26DSA-3407-1
dpkgsource(unstable)1.18.4

Notes

[squeeze] - dpkg <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems